nix-config/pkgs/change-audio/default.nix
Bruno BELANYI 405965dc72 pkgs: add explicit 'meta.mainProgram'
Since upstream has decided to deprecate the implied value when using
`lib.getExe` (see [1]), we should set it explicitly.

[1]: https://github.com/NixOS/nixpkgs/pull/246386
2023-08-06 20:13:08 +02:00

43 lines
898 B
Nix

{ lib, libnotify, makeWrapper, pamixer, stdenvNoCC }:
stdenvNoCC.mkDerivation rec {
pname = "change-audio";
version = "0.3.0";
src = ./change-audio;
nativeBuildInputs = [
makeWrapper
];
dontUnpack = true;
dontBuild = true;
installPhase = ''
mkdir -p $out/bin
cp $src $out/bin/change-audio
chmod a+x $out/bin/change-audio
'';
wrapperPath = lib.makeBinPath [
libnotify
pamixer
];
fixupPhase = ''
patchShebangs $out/bin/change-audio
wrapProgram $out/bin/change-audio --prefix PATH : "${wrapperPath}"
'';
meta = with lib; {
description = ''
A script to change the volume and notify about it
'';
homepage = "https://git.belanyi.fr/ambroisie/nix-config";
license = with licenses; [ mit ];
mainProgram = "change-audio";
maintainers = with maintainers; [ ambroisie ];
platforms = platforms.linux;
};
}