nix-config/modules/home/bitwarden/default.nix
Bruno BELANYI 4a01a50532
All checks were successful
ci/woodpecker/push/check Pipeline was successful
flake: bump inputs
And fix the update `pinentry` options in home-manager.
2024-03-16 19:49:00 +01:00

23 lines
470 B
Nix

{ config, lib, pkgs, ... }:
let
cfg = config.my.home.bitwarden;
in
{
options.my.home.bitwarden = with lib; {
enable = my.mkDisableOption "bitwarden configuration";
pinentry = mkPackageOption pkgs "pinentry" { default = [ "pinentry-tty" ]; };
};
config = lib.mkIf cfg.enable {
programs.rbw = {
enable = true;
settings = {
email = lib.my.mkMailAddress "bruno" "belanyi.fr";
inherit (cfg) pinentry;
};
};
};
}