nix-config/modules/home/atuin/default.nix
Bruno BELANYI 08f31c088b
All checks were successful
ci/woodpecker/push/check Pipeline was successful
home: atuin: explicitly set 'enter_accept'
2024-02-13 14:34:27 +00:00

34 lines
782 B
Nix

{ config, lib, ... }:
let
cfg = config.my.home.atuin;
in
{
options.my.home.atuin = with lib; {
enable = my.mkDisableOption "atuin configuration";
};
config = lib.mkIf cfg.enable {
programs.atuin = {
enable = true;
flags = [
# I *despise* this hijacking of the up key, even though I use Ctrl-p
"--disable-up-arrow"
];
settings = {
# The package is managed by Nix
update_check = false;
# I don't care for the fancy display
style = "compact";
# Get closer to fzf's fuzzy search
search_mode = "skim";
# Show long command lines at the bottom
show_preview = true;
# I like being able to edit my commands
enter_accept = false;
};
};
};
}