nix-config/flake.nix
Bruno BELANYI 723bc90852
Some checks are pending
ci/woodpecker/push/check Pipeline is pending
WIP: flake: add deploy-rs
2023-06-11 16:12:55 +01:00

93 lines
1.8 KiB
Nix

{
description = "NixOS configuration with flakes";
inputs = {
agenix = {
type = "github";
owner = "ryantm";
repo = "agenix";
ref = "main";
inputs = {
home-manager.follows = "home-manager";
nixpkgs.follows = "nixpkgs";
};
};
deploy-rs = {
type = "github";
owner = "serokell";
repo = "deploy-rs";
ref = "master";
inputs = {
flake-compat.follows = "flake-compat";
nixpkgs.follows = "nixpkgs";
utils.follows = "futils";
};
};
flake-compat = {
type = "github";
owner = "edolstra";
repo = "flake-compat";
ref = "master";
flake = false;
};
flake-parts = {
type = "github";
owner = "hercules-ci";
repo = "flake-parts";
ref = "main";
inputs = {
nixpkgs-lib.follows = "nixpkgs";
};
};
futils = {
type = "github";
owner = "numtide";
repo = "flake-utils";
ref = "main";
};
home-manager = {
type = "github";
owner = "nix-community";
repo = "home-manager";
ref = "master";
inputs = {
nixpkgs.follows = "nixpkgs";
};
};
nixpkgs = {
type = "github";
owner = "NixOS";
repo = "nixpkgs";
ref = "nixos-unstable";
};
nur = {
type = "github";
owner = "nix-community";
repo = "NUR";
ref = "master";
};
pre-commit-hooks = {
type = "github";
owner = "cachix";
repo = "pre-commit-hooks.nix";
ref = "master";
inputs = {
flake-compat.follows = "flake-compat";
flake-utils.follows = "futils";
nixpkgs.follows = "nixpkgs";
nixpkgs-stable.follows = "nixpkgs";
};
};
};
# Can't eta-reduce a flake outputs...
outputs = inputs: import ./flake inputs;
}