nix-config/modules/home/nixgl/default.nix
Bruno BELANYI f5a1181267
All checks were successful
ci/woodpecker/push/check Pipeline was successful
home: add 'nixgl'
2024-11-04 11:02:45 +00:00

18 lines
296 B
Nix

{ config, inputs, lib, ... }:
let
cfg = config.my.home.nixgl;
in
{
options.my.home.nixgl = with lib; {
enable = mkEnableOption "nixGL configuration";
};
config = lib.mkIf cfg.enable (lib.mkMerge [
{
nixGL = {
inherit (inputs.nixgl) packages;
};
}
]);
}